hdu 1102(最小生成树)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19579    Accepted Submission(s): 7474


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

 

Sample Output
179
昨天没写博客,今天开始练习图论算法
题意:给出每两个村庄之间修路所需的费用,然后有一些村庄的路已经修好了,每两个村庄之间有且仅有一条路,问修这些路的最小花费.
题解:因为题目点少,直接开的邻接矩阵了,先把连通的村庄的路初始化为0 ,然后利用prim算法求解.
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

const int N = 105;
const int INF = 99999999999;
int graph[N][N];
int low[N];
bool vis[N];

int prim(int n,int start){
    memset(vis,false,sizeof(vis));
    memset(low,false,sizeof(low));
    int pos = start,cost=0;
    vis[pos]=true;
    for(int i=1;i<=n;i++){
        low[i] = graph[pos][i];
    }
    for(int i=1;i<n;i++){
        int Min = INF;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&low[j]<Min){
                pos = j,Min = low[j];
            }
        }
        vis[pos]=true;
        cost+=Min;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&low[j]>graph[pos][j]) low[j] = graph[pos][j];
        }
    }
    return cost;
}

int main(){
    int n,m;
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&graph[i][j]);
            }
        }
        scanf("%d",&m);
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            graph[a][b]=graph[b][a] = 0;
        }
        printf("%d\n",prim(n,1));
    }
}

 

posted @ 2016-05-07 20:23  樱花庄的龙之介大人  阅读(186)  评论(0编辑  收藏  举报