hdu 1227(动态规划)

Fast Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2647    Accepted Submission(s): 1124


Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
 

 

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.
 

 

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.

Output a blank line after each test case.
 

 

Sample Input
6 3 5 6 12 19 20 27 0 0
 

 

Sample Output
Chain 1 Total distance sum = 8
 

 

Source
题意:在n个餐馆间建k个仓库,求所有餐馆到仓库和最小
分析:dp[i][j]表示前i个餐厅建j个仓库并且第j个仓库建在i点花费的最少代价
假设第 j-1个仓库建设在 k,那么前j个花费的代价为dp[k][j-1]+cost(k,i)cost(k,j)表示k-j的所有餐馆到仓库花费的最少代价
这题重要的是预处理
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#define N 205
using namespace std;

int v[N];
int dp[N][35];  ///dp[i][j]表示前i个餐厅建j个仓库并且第j个仓库建在i点花费的最少代价
///假设第 j-1个仓库建设在 k,那么前j个花费的代价为dp[k][j-1]+cost(k,i)
///cost(k,j)表示k-j的所有餐馆到仓库花费的最少代价
int main()
{
    int n,k;
    int t = 1;
    while(scanf("%d%d",&n,&k)!=EOF,n+k){
        for(int i=1;i<=n;i++) {
            scanf("%d",&v[i]);
        }
        for(int i=1;i<=n;i++){ ///必要的预处理,因为如果算第1个仓库的时候没有处理,后面的就算不出来了
            int cost=0;
            for(int j=1;j<=i;j++){
                cost+=v[i]-v[j];
            }
            dp[i][1]=cost;
        }
        for(int j=2;j<=k;j++){ ///枚举仓库数,1已经算过了
            for(int i=j;i<=n;i++){ ///枚举餐馆,从j开始,因为仓库数从j开始
                dp[i][j]=9999999999;
                for(int m=j-1;m<i;m++){
                    int cost = 0;
                    for(int c = m+1;c<i;c++){
                        cost += min(v[c]-v[m],v[i]-v[c]);
                    }
                    dp[i][j] = min(dp[i][j],dp[m][j-1]+cost);
                }
            }
        }
        int ans = 9999999999;
        for(int i=1;i<=n;i++){ ///还只算到dp[i][k] 后面的餐馆到其距离还未加上去
            int cost=0;
            for(int j=i+1;j<=n;j++){
                cost+=v[j]-v[i];
            }
            ans = min(ans,dp[i][k]+cost);
        }
        printf("Chain %d\nTotal distance sum = %d\n\n",t++,ans);
    }
}

 

posted @ 2016-04-22 20:10  樱花庄的龙之介大人  阅读(332)  评论(0编辑  收藏  举报