hdu 2955(概率转化,01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18808    Accepted Submission(s): 6941


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

 

Sample Input
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

 

Sample Output
2 4 6
 
题意:一群强盗想要抢劫银行,总共N(N <= 100)个银行,第i个银行的资金为Bi亿,抢劫该银行被抓概率Pi,问在被抓概率小于p的情况下能够抢劫的最大资金是多少?
题解:分析:至少一次被抓的概率要小于p,和hdu 1203 非常相似,抢劫第i个银行被抓的概率为pi,那么
不被抓的概率就为1-pi,定义dp[i] 代表获得能够获得i亿的情况下不被抓的最大概率,1-dp[i]代表被抓至少一次的最小概率
然后逆序枚举dp 得到第一个 1-dp[k] < p (k从V->0) 即为所求.
 
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include <math.h>
#define N 10050  ///背包容量 100*100
using namespace std;

int V[105];
double p[105];
double dp[N];  ///dp[i]表示抢劫i亿元能够不被抓的最大概率
int main()
{
    int tcase ;
    scanf("%d",&tcase);
    while(tcase--){
        int n;
        double _p;
        scanf("%lf%d",&_p,&n);
        int sum=0;
        for(int i=1;i<=n;i++){
            scanf("%d%lf",&V[i],&p[i]);
            sum +=V[i];
            p[i]=1-p[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1.0; ///初始化,获得0亿元不被抓的概率为1
        for(int i=1;i<=n;i++){
            for(int v = sum;v>=V[i];v--){
                dp[v] = max(dp[v],dp[v-V[i]]*p[i]);
            }
        }
        int max_value=0;
        for(int k = sum;k>=0;k--){
            if(1-dp[k]<_p) {
                max_value = k;
                break;
            }
        }
        printf("%d\n",max_value);
    }
    return 0;
}

 

posted @ 2016-04-15 11:15  樱花庄的龙之介大人  阅读(313)  评论(0编辑  收藏  举报