hdu 1025(最长上升子序列)

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21250    Accepted Submission(s): 6017


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

 

Sample Input
2 1 2 2 1 3 1 2 2 3 3 1
 

 

Sample Output
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
 
题意:有2n个城市,其中有n个富有的城市,n个贫穷的城市,其中富有的城市只在一种资源富有,且富有的城市之间富有的资源都不相同,贫穷的城市只有一种资源贫穷,且各不相同,现在给出一部分贫穷城市的需求,每个需求都是一个贫穷的向一个富有的城市要 资源,且每个富有的城市都想向贫穷的城市输入自己富有的那部分资源,现在为了运输要建设多条路,但是路与路之间不允许有交叉,求满足贫穷城市的各种要求最多可以建设多少条路。
 
题解:城市(资源)一一对应,对贫穷城市升序排列,想要最多建设路,那么就只能找最大的升序序列.
例 : 
poor:1 2 3 4 5
rich : 1 5 2 3 4
想要修建最多的路,那么肯定就是修 1-1 2-2 3-3 4-4了
LIS的O(n*log(n))算法,,去年做过了
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include <algorithm>
using namespace std;

struct city{
    int p,r;
}a[500055];
int c[500055];
int dp[500055];
int n;
int binsearch(int n,int value)
{
    int l=1, r=n;
    while(l<=r)
    {
        int mid = (l+r)/2;
        if( value > c[mid] && value<= c[mid+1] ) return mid+1;
        else if( value < c[mid] ) r = mid-1;
        else l = mid+1;
    }
}
int LIS()
{
    int i, j, Size= 1;
    c[1] = a[1].r;
    dp[1] = 1;
    for(int i=2; i<=n; ++i)
    {
        if( a[i].r <= c[1] ) j = 1;
        else if(a[i].r>c[Size] ) j=++Size;
        else j = binsearch(Size, a[i].r);
        c[j] = a[i].r;
        dp[i] = j;
    }
    return Size;
}
int cmp(city a,city b){
    return a.p<b.p;
}
int main()
{
    int cas=1;
    while(scanf("%d",&n)!=EOF)
    {
        int temp1,temp2;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&temp1,&temp2);
            a[i].p=temp1;
            a[i].r=temp2;
        }
        sort(a+1,a+n+1,cmp);
        printf("Case %d:\n",cas++);
        int temp=LIS();
        if(temp==1) printf("My king, at most 1 road can be built.\n\n");
        else  printf("My king, at most %d roads can be built.\n\n",temp);
    }
    return 0;
}

 

posted @ 2016-04-10 21:02  樱花庄的龙之介大人  阅读(150)  评论(0编辑  收藏  举报