1054 The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N(for example, 8), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤) and N (≤) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24


/*
    Name:
    Copyright:
    Author:  流照君
    Date: 2019/8/7 14:53:26
    Description:
*/
#include <iostream>
#include<string>
#include <algorithm>
#include <vector>
#include<map>
#define inf 90000000
using namespace std;
map<int,int> a;
int main(int argc, char** argv)
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    int n,m,temp;
    cin>>n>>m;
    int half=(n*m)/2;
    for(int i=1;i<=n*m;i++)
    {
        cin>>temp;
        a[temp]++;
        if(a[temp]>half)
        {
            cout<<temp<<endl;
            return 0;
        }
    }
    return 0;
}

map 的应用

 

posted @ 2019-08-07 15:22  流照君  阅读(126)  评论(0编辑  收藏  举报