武汉科技大学ACM :1008: A+B for Input-Output Practice (VIII)

Problem Description

Your task is to calculate the sum of some integers.

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6


#include <iostream>  
using namespace std;  
  
int main()  
{  
    int N;  
    cin >> N;  
    while (N--)  
    {  
        int M,sum = 0;  
        cin >> M;  
        while (M--)  
        {  
            int i;  
            cin >> i;  
            sum += i;  
        }  
        cout << sum << endl;  
        if (N != 0)cout << endl;//没有此行运行时会出现错误:Presentation Error  
    }  
  
return 0;  
}  

 

posted @ 2014-12-05 20:31  liuwt365  阅读(251)  评论(0编辑  收藏  举报