ACboy needs your help DP分组背包

这是一道分组背包问题,一开始看到这个题目只知道是求最优解的背包问题,接触到分组背包是第一次,借鉴了背包问题九讲上对这种问题的模板。

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input

2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0

Sample Output

3 4 6

算法

这个问题变成了每组物品有若干种策略:是选择本组的某一件,还是一件都不选。也就是说设f[k][v]表示前k组物品花费费用v能取得的最大权值,则有:

f[k][v]=max{f[k-1][v],f[k-1][v-c[i]]+w[i]|物品i属于第k组}

使用一维数组的伪代码如下:

for 所有的组k

    for v=V..0

        for 所有的i属于组k

            f[v]=max{f[v],f[v-c[i]]+w[i]}

注意这里的三层循环的顺续。“for v=V..0”这一层循环必须在“for 所有的i属于组k”之外。这样才能保证每一组内的物品最多只有一个会被添加到背包中。

小结

分组的背包问题将彼此互斥的若干物品称为一个组,这建立了一个很好的模型。不少背包问题的变形都可以转化为分组的背包问题,由分组的背包问题进一步可定义“泛化物品”的概念,十分有利于解题。

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    int m,n,t[1000],c[100][100];
    while(cin>>n>>m&&(n!=0||m!=0))
    {   memset(t,0,sizeof(t));
        int i,j,k;
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            cin>>c[i][j];
        for(i=0;i<n;i++)
            for(j=m;j>=0;j--)
                for(k=0;k<=j;k++)
                t[j]=max(t[j],(t[j-k]+c[i][k]));
                cout<<t[m]<<endl;
    }
    return 0;
}

 

posted on 2013-10-09 20:21  留梦言  阅读(232)  评论(0编辑  收藏  举报

导航