Counting Triangles

Description


Given an equilateral triangle with n the length of its side, program to count how many triangles in it. 


 



  


Input


The length n (n <= 500) of the equilateral triangle's side, one per line. 

process to the end of the file 


  


Output


The number of triangles in the equilateral triangle, one per line. 


  


Sample Input


 1
2
3 


  


Sample Output


 1
5

 

图...就是高中学归纳证明的一道题目吧....我也不会,百度了一波

#include<cstdio>
#include<cstring>
using namespace std;
int long long a[505],b[505],sum[505];
int main()
{ 
    int i,j,n;
  for(i=1;i<=500;i++)
   a[i]=i+a[i-1];
  for(i=2;i<=500;i++)
   b[i]=i-1+b[i-2];
  for(i=1;i<=500;i++)
   sum[i]=sum[i-1]+a[i]+b[i];
  while(scanf("%d",&n)!=EOF)
   printf("%lld\n",sum[n]);
  return 0;
}

 

posted @ 2018-07-19 22:19  RAIN-code  阅读(283)  评论(0编辑  收藏  举报