HDU 1520(树形DP)

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9137    Accepted Submission(s): 3917


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

 

Output
Output should contain the maximal sum of guests' ratings.
 

 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

 

Sample Output
5
树形DP和线性DP差不多.   dfs一下。
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
int n;
int happy[6005];
vector<int> son[6005];
int dp[6005][3];
int vis[6005];
void dfs(int now)
{
    dp[now][1] = happy[now];
    dp[now][0] = 0;
    for(int i=0;i<son[now].size();i++)
    {
        int nex = son[now][i];
        dfs(nex);
        dp[now][1] += dp[nex][0];
        dp[now][0] += max(dp[nex][0],dp[nex][1]);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&happy[i]);
        }
        int l,k;
        while(1)
        {
            scanf("%d %d",&l,&k);
            if(l==0&&k==0) break;
            son[k].push_back(l);
            vis[l] = 1;
        }
        int father = 0;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i])
            {
                father = i;
                break;
            }
        }
        dfs(father);
        printf("%d\n",max(dp[father][0],dp[father][1]));
        for(int i=1;i<=n;i++) son[i].clear();
    }
    return 0;
}

 

posted @ 2016-08-08 00:42  卷珠帘  阅读(159)  评论(0编辑  收藏  举报