1120 Friend Numbers (20分)

Two integers are called "friend numbers" if they share the same sum of their digits, and the sum is their "friend ID". For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID's among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 1.

Output Specification:

For each case, print in the first line the number of different frind ID's among the given integers. Then in the second line, output the friend ID's in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12
 

Sample Output:

4
3 6 9 26

朋友数,关于一个数字每个数字相加,是一个朋友ID,我们要从小到大打印朋友ID。

#include <iostream>
#include <set>
using namespace std;
int main() {
    set<int> s;
    int N, tmp;
    scanf("%d", &N);
    while(N--) {
        int sum = 0;
        scanf("%d", &tmp);
        while(tmp != 0) {
            sum += tmp % 10;
            tmp /= 10;
        }
        s.insert(sum);
    }
    auto it = s.begin();
    printf("%lu\n%d", s.size(), *it++);
    while(it != s.end()) printf(" %d", *it++);
    return 0;
}

 

posted @ 2020-05-07 16:56  SteveYu  阅读(122)  评论(0编辑  收藏  举报