PAT Basic 1010 一元多项式求导 (25 分)(活用stringstream,昨天学习的)

设计函数求一元多项式的导数。(注:xn​​(n为整数)的一阶导数为nxn1​​。)

输入格式:

以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过 1000 的整数)。数字间以空格分隔。

输出格式:

以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是 0,但是表示为 0 0

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

#include <iostream>
#include <sstream>
using namespace std;
int main(){
    /**使用stringstream进行字符流读入一行*/
    stringstream sline;
    string line;
    getline(cin,line);
    sline<<line;
    stringstream res;/**储存最后打印字符串*/
    /**开始计算*/
    int a,b;
    while(sline>>a>>b){
        a*=b;b--;
        if(a!=0) {
            res<<a<<" "<<b<<" ";
        }
    }
    /**输出*/
    if(res.str()=="") cout<<"0 0";
    else cout<<res.str().substr(0,res.str().length()-1);
    system("pause");
    return 0;
}

 



posted @ 2019-08-01 04:12  SteveYu  阅读(145)  评论(0编辑  收藏  举报