FatMouse' Trade

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35608    Accepted Submission(s): 11680


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500

 

 

#include<iostream>
#include<iomanip>
#include<algorithm>
#include<cstdio>
using namespace std;

struct tread
{
double javaBean,catfood;
double per;
};

bool cmp(tread a, tread b)
{
return a.per>b.per;
}

int main()
{
tread *t;
int M,N,i;
double tot;
while(cin>>M>>N)
{
if(M==-1&&N==-1)break;
t=new tread[N];
tot=0.0;
for(i=0;i<N;i++)
{
cin>>t[i].javaBean>>t[i].catfood;
if(t[i].catfood!=0)
t[i].per=t[i].javaBean/t[i].catfood;
else
{
tot=tot+t[i].javaBean;
i--;
N--;
}
}
sort(t,t+N,cmp);

for(i=0;i<N&&M>=t[i].catfood;i++)
{
tot=tot+t[i].javaBean;
M=M-t[i].catfood;
}
if(i<N)
tot=tot+M*t[i].per;
// cout<<setprecision(3)<<tot<<endl;
printf("%.3f\n",tot);
}
delete[] t;
return 0;
}

posted @ 2013-11-14 16:49  偶尔会寂寞  阅读(164)  评论(0编辑  收藏  举报