PAT (Advanced Level) Practice 1008 Elevator (20 分) 凌宸1642

PAT (Advanced Level) Practice 1008 Elevator (20 分) 凌宸1642

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

译:我们城市最高的建筑只有一部电梯。一个请求列表由 N 个正整数组成。这些数字表示电梯将会在哪些指定楼层停靠。电梯上升一层花费 6 秒 的时间,电梯下降一层花费 4 秒的时间。电梯每次停靠会停留 5 秒的时间


Input Specification (输入说明):

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

译:每个输入文件包含一个测试用例,每个用例包含一个整数 N , 紧跟着后面的是 N 个正整数。输入所有的数字都小于 100.


Output Specification (输出说明):

For each test case, print the total time on a single line.

译:对于每个测试用例,在一行中输出耗费时间的总和。


Sample Input (样例输入):

3 2 3 1

Sample Output (样例输出):

41

The Idea:

首先,有 N 个数据意味着需要停留 N 次,所以可以直接算出停留的时间就是 N * 5 , 然后再遍历列表中的所有数,如果是上升,结果就加上 楼层差乘以 6 秒,如果是下降,结果就加上 楼层差乘以 4 秒, 遍历结束,得到的总和就是答案。


The Codes:

#include<bits/stdc++.h>
using namespace std ;
#define MAX 110
int ele[MAX] = { 0 } ;
int main(){
	int n , sum , t ;
	scanf("%d" , &n) ;
	sum = n * 5 ; // 所有的停靠时间
	for(int i = 1 ; i <= n ; i ++) scanf("%d" , &ele[i]) ;
	for(int i = 1 ; i <= n ; i ++){
		if(ele[i] > ele[i - 1]) sum += (ele[i] - ele[i - 1]) * 6 ;  // 加上上升的时间
		else sum += (ele[i - 1] - ele[i]) * 4 ; // 加上下降的时间
	}
	printf("%d\n" , sum) ;
	return 0 ;
}

posted @ 2021-04-01 09:53  凌宸1642  阅读(41)  评论(0编辑  收藏  举报