HDU-1019 Least Common Multiple

Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

Sample Input

2

3 5 7 15

6 4 10296 936 1287 792 1

 

Sample Output

105

10296


 

最小公倍数等于两数相乘除以最大公因数。(欧几里得算法)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
 
int main(void)
{
    int t;
    long func(long, long);
     
    cin >> t;
    while(t--)
    {
        long long q = 1;
        int m;
        long num;
 
         
        cin >> m;
        while(m--)
        {
            cin >> num;
            q = num/func(q, num)*q;
        }
        cout << q << endl;
         
    }
     
    return 0;
}
 
 
long func(long a, long b)
{
    long q = max(a, b);
    long p = a+b-q;
     
    while(q%p!=0)
    {
        p = q+p;
        q = p-q;
        p = p-q;
        p = p%q;
    }
    return p;
}

 

posted @   limyel  阅读(118)  评论(0编辑  收藏  举报
编辑推荐:
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
· 现代计算机视觉入门之:什么是图片特征编码
· .NET 9 new features-C#13新的锁类型和语义
阅读排行:
· Spring AI + Ollama 实现 deepseek-r1 的API服务和调用
· 《HelloGitHub》第 106 期
· 数据库服务器 SQL Server 版本升级公告
· 深入理解Mybatis分库分表执行原理
· 使用 Dify + LLM 构建精确任务处理应用
点击右上角即可分享
微信分享提示