Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题意:
    求最长上升子序列。
思路:
    动态规划,建立一个数组,存放每一个阶段的最长公共子序列的个数。
 
代码如下:
 

#include <iostream>

using namespace std;

int map[1005];
int num[1005];

int main()
{
 int n, i, j;
 cin >> n;
 for (i = 0; i < n; i++)
 {
  cin >> map[i];
  num[i] = 1;
 }
 
 for (i = 0; i < n; i++)
 {
  for (j = 0; j <= i; j++)
  {
   if (map[j] < map[i])
   {
    if (num[j] + 1 > num[i])
    {
     num[i] = num[j] + 1;
    }
   }
  }
 }
 int m = 0;
 
 for (i = 0; i < n; i++)
 {
  if (num[i] > m)
  {
   m = num[i];
  }
 }
 cout << m << endl;
 return 0;
}

posted on 2013-05-11 20:23  认真的看我  阅读(126)  评论(0编辑  收藏  举报