POJ 3077 : Rounders

Rounders
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7827 Accepted: 5062

Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on …

Input
Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output
For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.

Sample Input
9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output
20
10
4
5
100
10000000
50000000
2000
500

水题,对一个数,从左到右判定,遇到4先待定,遇到能解决的就可以直接输出。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

int wei[15];

int main()
{
    int count;
    cin>>count;

    while(count--)
    {
        int wang,i,j;
        int str=0;

        memset(wei,0,sizeof(wei));

        cin>>wang;

        i=wang;

        while(i)
        {
            wei[++str]=i%10;
            i /=10;
        }
        for(j=str-1;j>=0;j--)
        {
            if(wei[j]==4)
                continue;
            else if(wei[j]>4)
            {
                wei[str]++;
                break;
            }
            else
                break;
        }
        int result=wei[str]*pow((double)10,str-1);
        cout<<result<<endl;
    }   
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-06-25 15:07  光速小子  阅读(153)  评论(0编辑  收藏  举报

导航