POJ 1565:Skew Binary

Skew Binary
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10676   Accepted: 6807

Description

When a number is expressed in decimal, the kth digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 
81307(10) = 8 * 10^4 + 1 * 10 ^3 + 3 * 10^2 + 0 * 10^1 + 7 * 10^0 
= 80000 + 1000 + 300 + 0 + 7 
= 81307. 

When a number is expressed in binary, the kth digit represents a multiple of 2^k . For example, 

10011(2) = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 1 * 2^0 
= 16 + 0 + 0 + 2 + 1 
= 19. 

In skew binary, the kth digit represents a multiple of 2^(k+1)-1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example, 

10120(skew) = 1 * (2^5-1) + 0 * (2^4-1) + 1 * (2^3-1) + 2 * (2^2-1) + 0 * (2^1-1) 
= 31 + 0 + 7 + 6 + 0 
= 44. 

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.) 

Input

The input contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

Output

For each number, output the decimal equivalent. The decimal value of n will be at most 2^31-1 = 2147483647.

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output

44
2147483646
3
2147483647
4
7
1041110737

大水题。

代码:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

string test;

int main()
{
	while(cin>>test)
	{
		if(test=="0")
			break;
		
		int len = test.length();
		int i,k=1,result=0;

		for(i=len-1;i>=0;i--)
		{
			result = result+ (int)(test[i]-'0')*(int)(pow((double)2,k)-1);
			k++;
		}
		cout<<result<<endl;
	}
	return 0;
}




版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-06-30 11:00  光速小子  阅读(141)  评论(0编辑  收藏  举报

导航