POJ 3438:Look and Say

Look and Say
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 9196   Accepted: 5566

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input

3
122344111
1111111111
12345

Sample Output

1122132431
101
1112131415

洪水题,看着读这个数,再输出。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

string s;

void solve()
{
	int i,j;
	int len=s.length();
	
	for(i=0;i<len;i++)
	{
		int result=1;
		for(j=i+1;j<len;j++)
		{
			if(s[j]==s[i])
			{
				result++;
			}
			else
			{
				break;
			}
		}
		cout<<result<<s[i];
		i=i+result-1;
	}
	cout<<endl;
}

int main()
{
	int Test;
	cin>>Test;
	
	while(Test--)
	{
		cin>>s;
		solve();
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-31 15:14  光速小子  阅读(172)  评论(0编辑  收藏  举报

导航