POJ 1562:Oil Deposits

Oil Deposits
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 14462   Accepted: 7875

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

给一个表,问连着的@都多少堆,对角线、上下左右挨着一个就算连上了。

深搜入门题,对准@可劲的搜,能搜100块绝不搜80。计算循环了多少次即可。

代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int row,col;
char value[110][110];
int met[110][110];

void dfs(int i,int j)
{
	met[i][j]=1;
	if(met[i-1][j-1]==0&&value[i-1][j-1]=='@')
		dfs(i-1,j-1);
	if(met[i-1][j]==0&&value[i-1][j]=='@')
		dfs(i-1,j);
	if(met[i-1][j+1]==0&&value[i-1][j+1]=='@')
		dfs(i-1,j+1);
	if(met[i][j+1]==0&&value[i][j+1]=='@')
		dfs(i,j+1);
	if(met[i+1][j+1]==0&&value[i+1][j+1]=='@')
		dfs(i+1,j+1);
	if(met[i+1][j]==0&&value[i+1][j]=='@')
		dfs(i+1,j);
	if(met[i+1][j-1]==0&&value[i+1][j-1]=='@')
		dfs(i+1,j-1);
	if(met[i][j-1]==0&&value[i][j-1]=='@')
		dfs(i,j-1);
}

int main()
{
	int i,j;
	while(cin>>row>>col)
	{
		if(row+col==0)
			break;

		memset(met,0,sizeof(met));

		for(i=1;i<=row;i++)
		{
			cin>>value[i]+1;
		}
		int result=0;
		for(i=1;i<=row;i++)
		{
			for(j=1;j<=col;j++)
			{
				if(value[i][j]=='@'&&met[i][j]==0)
				{
					dfs(i,j);
					result++;
				}
			}
		}
		cout<<result<<endl;
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

posted on 2015-07-31 16:06  光速小子  阅读(170)  评论(0编辑  收藏  举报

导航