A1088. Rational Arithmetic (20)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format "a1/b1 a2/b2". The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is "number1 operator number2 = result". Notice that all the rational numbers must be in their simplest form "k a/b", where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output "Inf" as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;

//求最大公约数
long long gcd (long long a,long long b)
{
  if(b==0)return a; 
  else
  {
  return gcd(b,a%b);    
  }
      
} 
 
 struct Fraction{
     long long up,down;
     }a,b;
     
Fraction reduction (Fraction res)
{
    if(res.down<0)
    {
        res.up=-1*res.up;
        res.down=-1*res.down;
    }
    if(res.up==0)
    {
        res.down=1;
        }else
        {
        int d=gcd(abs(res.up),abs(res.down));
        res.up/=d;
        res.down/=d;
        }
     return res;   
}     


Fraction add(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.down+a.down*b.up;
    return reduction(res);
    }
Fraction minusF(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.down-a.down*b.up;
    return reduction(res);
    }
Fraction multi(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.down;
    res.up=a.up*b.up;
    return reduction(res);
    }

Fraction divide(Fraction a,Fraction b)
{
    Fraction res;
    res.down=a.down*b.up;
    res.up=a.up*b.down;
    return reduction(res);
    }

void show(Fraction r)
{
    r=reduction(r);
    if(r.up<0)
    {
      printf("(");
    }    
    if(r.down==1)printf("%lld",r.up);
    else if(abs(r.up)>r.down)
    {
      printf("%lld %lld/%lld",r.up/r.down,abs(r.up)%r.down,r.down);
    }else 
    {
       printf("%lld/%lld",r.up,r.down);
    }
    if(r.up<0)
    {
      printf(")");
    }  

}
int main(int argc, char* argv[])
{

    scanf("%lld/%lld %lld/%lld",&a.up,&a.down,&b.up,&b.down);
    show(a);printf(" + ");show(b);printf(" = ");show(add(a,b));printf("\n");
    show(a);printf(" - ");show(b);printf(" = ");show(minusF(a,b));printf("\n");
    show(a);printf(" * ");show(b);printf(" = ");show(multi(a,b));printf("\n");
    show(a);printf(" / ");show(b);printf(" = ");

    if(b.up==0)printf("Inf");
    else show(divide(a,b));printf("\n");
    system("pause"); 
    return 0;
}

 

posted @ 2015-03-13 17:45  Joilee  阅读(195)  评论(0编辑  收藏  举报