计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51606    Accepted Submission(s): 19567

Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 
Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
Output
对于每组输入数据,输出一行,结果保留两位小数。
Sample Input
0 0 0 1
0 1 1 0
Sample Output
1.00
1.41
 
Author
lcy

Source

 
Recommend
JGShining
代码如下:
import java.util.Scanner;
public class Main{
    public static void main(String[] args){
        Scanner scan = new Scanner(System.in);
        double x1, x2, y1, y2, a, b, ans;
        while (scan.hasNextDouble()){
            x1 = scan.nextDouble();
            y1 = scan.nextDouble();
            x2 = scan.nextDouble();
            y2 = scan.nextDouble();
            a = x1 - x2;
            b = y1 - y2; 
            ans = Dis(a, b);
            System.out.printf("%.2f",ans);
            System.out.println();
        }
    }
    //求距离的函数
    public static double Dis(double x, double y){
        double D;
        D = Math.sqrt(x * x + y * y);
        return D;
    }
}

 

posted on 2012-05-26 01:36  Stephen Li  阅读(437)  评论(0编辑  收藏  举报