随笔 - 148,  文章 - 0,  评论 - 6,  阅读 - 88384
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

Building a Space Station

Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 2585

 

Accepted: 1362

Description

You are a member of the space station engineering team, and are assigned a task in the construction process of the station. You are expected to write a computer program to complete the task. 
The space station is made up with a number of units, called cells. All cells are sphere-shaped, but their sizes are not necessarily uniform. Each cell is fixed at its predetermined position shortly after the station is successfully put into its orbit. It is quite strange that two cells may be touching each other, or even may be overlapping. In an extreme case, a cell may be totally enclosing another one. I do not know how such arrangements are possible. 

All the cells must be connected, since crew members should be able to walk from any cell to any other cell. They can walk from a cell A to another cell B, if, (1) A and B are touching each other or overlapping, (2) A and B are connected by a `corridor', or (3) there is a cell C such that walking from A to C, and also from B to C are both possible. Note that the condition (3) should be interpreted transitively. 

You are expected to design a configuration, namely, which pairs of cells are to be connected with corridors. There is some freedom in the corridor configuration. For example, if there are three cells A, B and C, not touching nor overlapping each other, at least three plans are possible in order to connect all three cells. The first is to build corridors A-B and A-C, the second B-C and B-A, the third C-A and C-B. The cost of building a corridor is proportional to its length. Therefore, you should choose a plan with the shortest total length of the corridors. 

You can ignore the width of a corridor. A corridor is built between points on two cells' surfaces. It can be made arbitrarily long, but of course the shortest one is chosen. Even if two corridors A-B and C-D intersect in space, they are not considered to form a connection path between (for example) A and C. In other words, you may consider that two corridors never intersect. 

Input

The input consists of multiple data sets. Each data set is given in the following format. 


x1 y1 z1 r1 
x2 y2 z2 r2 
... 
xn yn zn rn 

The first line of a data set contains an integer n, which is the number of cells. n is positive, and does not exceed 100. 

The following n lines are descriptions of cells. Four values in a line are x-, y- and z-coordinates of the center, and radius (called r in the rest of the problem) of the sphere, in this order. Each value is given by a decimal fraction, with 3 digits after the decimal point. Values are separated by a space character. 

Each of x, y, z and r is positive and is less than 100.0. 

The end of the input is indicated by a line containing a zero. 

Output

For each data set, the shortest total length of the corridors should be printed, each in a separate line. The printed values should have 3 digits after the decimal point. They may not have an error greater than 0.001. 

Note that if no corridors are necessary, that is, if all the cells are connected without corridors, the shortest total length of the corridors is 0.000. 

Sample Input

3
10.000 10.000 50.000 10.000
40.000 10.000 50.000 10.000
40.000 40.000 50.000 10.000
2
30.000 30.000 30.000 20.000
40.000 40.000 40.000 20.000
5
5.729 15.143 3.996 25.837
6.013 14.372 4.818 10.671
80.115 63.292 84.477 15.120
64.095 80.924 70.029 14.881
39.472 85.116 71.369 5.553
0

Sample Output

20.000
0.000
73.834

Source

Japan 2003 Domestic

 解题报告:题意就是在三维空间内有若干个球,求让球之间都能相连(间接能到达也行)所用的长度最小是多少!就是求最小生成树,我用的是Prim算法;

代码如下:

复制代码
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
using namespace std;
const int MAX = 110;
const double INF = 0x7fffffff;
int n, visit[MAX];
double map[MAX][MAX], dis[MAX], ans;
struct node
{
    double x;
    double y;
    double z;
    double r;
}globe[MAX];//储存球的球心位置及大小
double Max(double a, double b)
{
    return a > b ? a : b;
}
double Dis(int i, int j)//求两球之间的距离若结果小于0说明两球有重合的部分
{
    double a = globe[i].x - globe[j].x;
    double b = globe[i].y - globe[j].y;
    double c = globe[i].z - globe[j].z;
    return sqrt(a * a + b * b + c * c) - globe[i].r - globe[j].r;
}
void Prim()
{
    int i, j, p;
    double min;//注意这儿应该是double类型!
    memset(visit, 0, sizeof(visit));
    memset(dis, 0, sizeof(dis));
    for (i = 1; i <= n; ++i)//初始化
    {
        dis[i] = map[1][i];
    }
    visit[1] = 1;
    for (i = 1; i < n; ++i)
    {
        min = INF;//初始化假设最小距离无限大
        for (j = 1; j <= n; ++j)
        {
            if (!visit[j] && min > dis[j])
            {
                min = dis[j];
                p = j;
            }
        }
        visit[p] = 1;
        if (min < INF)
        {
            ans += min;
        }
        for (j = 1; j <= n; ++j)
        {
            if (!visit[j] && dis[j] > map[p][j])//路径更新
            {
                dis[j] = map[p][j];
            }
        }
    }
}
int main()
{
    int i, j;
    while (scanf("%d", &n) != EOF && n)
    {
        memset(globe, 0, sizeof(globe));
        memset(map, 0, sizeof(map));
        for (i = 1; i <= n; ++i)
        {
            scanf("%lf%lf%lf%lf", &globe[i].x, &globe[i].y, &globe[i].z, &globe[i].r);
        }
        for (i = 1; i <= n; ++i)
        {
            for (j = 1; j < i; ++j)
            {
                double d = Dis(i, j);//两球间的距离
                map[i][j] = map[j][i] = Max(0, d);
            }
        }
        ans = 0;
        Prim();
        printf("%.3lf\n", ans);
    }
    return 0;
}
复制代码
posted on   Stephen Li  阅读(345)  评论(0编辑  收藏  举报
编辑推荐:
· AI与.NET技术实操系列:基于图像分类模型对图像进行分类
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
阅读排行:
· 25岁的心里话
· 闲置电脑爆改个人服务器(超详细) #公网映射 #Vmware虚拟网络编辑器
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 零经验选手,Compose 一天开发一款小游戏!
· 一起来玩mcp_server_sqlite,让AI帮你做增删改查!!
点击右上角即可分享
微信分享提示