随笔 - 148,  文章 - 0,  评论 - 6,  阅读 - 88367
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

Risk


Time Limit: 2 Seconds Memory Limit: 65536 KB


Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player's turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.

The following connection diagram illustrates the sample input. 


Input

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.

There can be multiple test sets in the input; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.
Output

For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.
Sample Input

1 3
2 3 4
3 4 5 6
1 6
1 7
2 12 13
1 8
2 9 10
1 11
1 11
2 12 17
1 14
2 14 15
2 15 16
1 16
1 19
2 18 19
1 20
1 20
5
1 20
2 9
19 5
18 19
16 20
Sample Output

Test Set #1
1 to 20: 7
2 to 9: 5
19 to 5: 6
18 to 19: 2
16 to 20: 2


Source: South Central USA 1997

Submit Status

 

解题报告:题意:就是求最短路径,一共有20个顶点,一开始是19行,每一行第一个数代表与这个顶点相连的个数,后面就是他们的关系!且每个权值都为1,最短路径可以用Dijkstra算法和Floyd算法实现,因为很久没有写最短路径的代码了!的确有点生!用Dijkstra算法时一开始TLE(输入的问题)又PE(粗心没有注意到换行)了一回!哎!悲惨呀,下面是两个算法的实现!

方法一:Dijkstra(迪杰斯特拉算法)

代码如下:

复制代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int N = 25;
const int INF=99999999;
int visit[N],map[N][N],dis[N];
void Dijkstra(int begin,int end)
{
int i,j,mark,min;
memset(dis,0,sizeof(dis));
memset(visit,0,sizeof(visit));
for(i=1;i<=20;i++)
{
dis[i]=map[begin][i];
}
visit[begin]=1;
dis[begin]=0;
for(i=1;i<=20;i++)
{
min=INF;
for(j=1;j<=20;j++)
{
if(!visit[j]&&min>dis[j])
{
min=dis[j];
mark=j;
}
}
if(min==INF)
{
break;
}
visit[mark]=1;
for(j=1;j<=20;j++)
{
if(!visit[j]&&dis[j]>map[mark][j]+dis[mark])
{
dis[j]=map[mark][j]+dis[mark];
}
}
}
}
int main()
{
int i,count,j,n,k,v,begin,end;
count=1;
while(scanf("%d",&k)!=EOF)
{
memset(map,0,sizeof(map));//初始化
for(i=0;i<=N;i++)
{
for(j=0;j<=N;j++)
{
map[i][j]=INF;
}
}
for(j=0;j<k;j++)//对输入第一行的特殊处理
{
scanf("%d",&v);
map[1][v]=map[v][1]=1;
}
for(i=2;i<=19;i++)
{
scanf("%d",&k);
for(j=0;j<k;j++)
{
scanf("%d",&v);
map[i][v]=map[v][i]=1;
}
}
printf("Test Set #%d\n",count);
count++;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&begin,&end);
Dijkstra(begin,end);
printf("%d to %d: %d\n",begin,end,dis[end]);
}
printf("\n");
}
return 0;
}
复制代码


 

方法二:Floyd(弗洛伊德算法)

代码如下:

复制代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
using namespace std;
const int N = 25;
const int INF=99999999;
int map[N][N];
void Floyd(int n)
{
int i,j,k;
for(k=1;k<=20;k++)
{
for(i=1;i<=20;i++)
{
for(j=1;j<=20;j++)
{
if(map[i][j]>map[i][k]+map[k][j])
{
map[i][j]=map[i][k]+map[k][j];
}
}
}
}
}
int main()
{
int i,count,j,n,k,v,begin,end;
count=1;
while(scanf("%d",&k)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<=N;i++)
{
for(j=0;j<=N;j++)
{
if(i==j)
{
map[i][j]=0;
}
else
{
map[i][j]=INF;
}
}
}
for(j=0;j<k;j++)
{
scanf("%d",&v);
map[1][v]=map[v][1]=1;
}
for(i=2;i<=19;i++)
{
scanf("%d",&k);
for(j=0;j<k;j++)
{
scanf("%d",&v);
map[i][v]=map[v][i]=1;
}
}
Floyd(20);
printf("Test Set #%d\n",count);
count++;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&begin,&end);
printf("%d to %d: %d\n",begin,end,map[begin][end]);
}
printf("\n");
}
return 0;
}
复制代码

 

posted on   Stephen Li  阅读(525)  评论(0编辑  收藏  举报
编辑推荐:
· AI与.NET技术实操系列:基于图像分类模型对图像进行分类
· go语言实现终端里的倒计时
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
阅读排行:
· 25岁的心里话
· 闲置电脑爆改个人服务器(超详细) #公网映射 #Vmware虚拟网络编辑器
· 基于 Docker 搭建 FRP 内网穿透开源项目(很简单哒)
· 零经验选手,Compose 一天开发一款小游戏!
· 一起来玩mcp_server_sqlite,让AI帮你做增删改查!!
点击右上角即可分享
微信分享提示