Fork me on GitHub

Uva 10110 - Light, more light

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output "yes" if the light is on otherwise "no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan 
Suman Mahbub 
01-04-2001

 

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    long long n, m;
    while(cin>>n)
    {
        if(n == 0) break;
        m = (long long)sqrt(n);
        if(m*m == n) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}

解题思路:

从测试数据可以看出,刚开始灯都是关着的状态,如果对其操作了偶数次,那么最后还是关着的状态,此刻应该输出no,那么能整除它的数的个数是几还是偶,那就要看它是不是完全平方数了,因为如果它是完全平方数,那么开根出来的那个数由于没有跟它对应的那个数,那么这就说明能整除这个完全平方数的个数是奇数,此刻就达到了灯开着的要求了,此刻输出“yes”

 

posted @ 2013-03-08 18:30  Gifur  阅读(424)  评论(0编辑  收藏  举报
TOP