Fork me on GitHub

UVa 11044 - Searching for Nessy

Searching for Nessy

The Loch Ness Monsteris a mysterious and unidentified animal said to inhabit Loch Ness,  a large deep freshwater loch near the city of Inverness in northern Scotland. Nessie is usually categorized as a type of lake monster. http://en.wikipedia.org/wiki/Loch_Ness_Monster

 

 

In July 2003, the BBC reported an extensive investigation of Loch Ness by a BBC team, using 600 separate sonar beams, found no trace of any ¨sea monster¨ (i.e., any large animal, known or unknown) in the loch. The BBC team concluded that Nessie does not exist. Now we want to repeat the experiment.

 

Given a grid of n rows and m columns representing the loch, 6$ \le$n, m$ \le$10000, find the minimum number s of sonar beams you must put in the square such that we can control every position in the grid, with the following conditions:

 

  • one sonar occupies one position in the grid; the sonar beam controls its own cell and the contiguous cells;
  • the border cells do not need to be controlled, because Nessy cannot hide there (she is too big).

For example,

 

$\textstyle \parbox{.5\textwidth}{\begin{center}\mbox{}\epsfbox{p11044.eps}\end{center}}$$\textstyle \parbox{.49\textwidth}{\begin{center}\mbox{}\epsfbox{p11044a.eps}\end{center}}$

 

\epsfbox{p11044b.eps}

where X represents a sonar, and the shaded cells are controlled by their sonar beams; the last figure gives us a solution.

 

Input

The first line of the input contains an integer, t, indicating the number of test cases. For each test case, there is a line with two numbers separated by blanks, 6$ \le$n, m$ \le$10000, that is, the size of the grid (nrows and m columns).

 

Output

For each test case, the output should consist of one line showing the minimum number of sonars that verifies the conditions above.

Sample Input

 3
6 6
7 7
9 13

 

Sample Output

 
4
4
12


#include<stdio.h>
#include<math.h>

int main()
{
    int T, n, m;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &n, &m);
        if((n-2)%3 != 0) n = (n-2)/3 + 1;
        else n = (n-2)/3;
        if((m-2)%3 != 0) m = (m-2)/3 + 1;
        else m = (m-2)/3;
        printf("%d\n", n*m);
    }
    return 0;
}

解题思路:
怪不得通过率那么高,求格中九宫格的最小数量,而且注意题目说了边上的格子是可以不算的,所以可以减去2在进行整除3,当然,如果除不尽当然还是再加上一个九宫格

posted @ 2013-03-05 12:35  Gifur  阅读(333)  评论(0编辑  收藏  举报
TOP