Fork me on GitHub

Uva 784 - Maze Exploration

  Maze Exploration 

A maze of rectangular rooms is represented on a two dimensional grid as illustrated in figure 1a. Each point of the grid is represented by a character. The points of room walls are marked by the same character which can be any printable character different than `*', `_' and space. In figure 1 this character is `X'. All the other points of the grid are marked by spaces.

 

               XXXXXXXXXXXXXXXXXXXXX             XXXXXXXXXXXXXXXXXXXXX
               X   X   X   X   X   X             X###X###X###X   X   X
               X           X   X   X             X###########X   X   X
               X   X   X   X   X   X             X###X###X###X   X   X
               XXXXXX XXX XXXXXXXXXX             XXXXXX#XXX#XXXXXXXXXX
               X   X   X   X   X   X             X   X###X###X###X###X
               X   X     *         X             X   X###############X
               X   X   X   X   X   X             X   X###X###X###X###X
               XXXXXXXXXXXXXXXXXXXXX             XXXXXXXXXXXXXXXXXXXXX
a) Initial maze                    b) Painted maze

Figure 1. Mazes of rectangular rooms

All rooms of the maze are equal sized with all walls 3 points wide and 1 point thick as illustrated in figure 2. In addition, a wall is shared on its full length by the separated rooms. The rooms can communicate through doors, which are positioned in the middle of walls. There are no outdoor doors.

 

                     door
                       |
                     XX XX
                     X . X   measured from within the room
               door - ...--  walls are 3 points wide
                     X . X__
                     XXXXX  |
                       |___  walls are one point thick
Figure 2. A room with 3 doors

Your problem is to paint all rooms of a maze which can be visited starting from a given room, called the `start room' which is marked by a star (`*') positioned in the middle of the room. A room can be visited from another room if there is a door on the wall which separates the rooms. By convention, a room is painted if its entire surface, including the doors, is marked by the character `#' as shown in figure 1b.

 

Input 

The program input is a text file structured as follows:

 

1.
The first line contains a positive integer which shows the number of mazes to be painted.
2.
The rest of the file contains the mazes.

The lines of the input file can be of different length. The text which represents a maze is terminated by a separation line full of underscores (`_'). There are at most 30 lines and at most 80 characters in a line for each maze

The program reads the mazes from the input file, paints them and writes the painted mazes on the standard output.

 

Output 

The output text of a painted maze has the same format as that which has been read for that maze, including the separation lines. The example below illustrates a simple input which contains a single maze and the corresponding output.

 

Sample Input 

2
XXXXXXXXX
X   X   X
X *     X
X   X   X
XXXXXXXXX
X   X
X   X
X   X
XXXXX
_____
XXXXX
X   X
X * X
X   X
XXXXX
_____

 

Sample Output 

XXXXXXXXX
X###X###X
X#######X
X###X###X
XXXXXXXXX
X   X
X   X
X   X
XXXXX
_____
XXXXX
X###X
X###X
X###X
XXXXX
_____

 

 


Miguel Revilla 
2001-01-05
 
/*填充房间
 *Author:xueying
 *Time: 2013-3-28 21:30:24
 *Rank: 464/3636
 *Verdict: Accept(1y)
 *解题思路:输入处理,四个方向深度查找
 */ 

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

void Traverse(char (*maze)[82], int cnt, int row, int column)
{
    maze[row][column] = '#';
    int i, j, len;
    for(i=row, j=column-1; j>=0 && maze[i][j] == ' '; --j) Traverse(maze, cnt, i, j);
    for(i=row, j=column+1, len=strlen(maze[i]); j<len && maze[i][j] == ' '; ++j) Traverse(maze, cnt, i, j);
    for(i=row-1, j=column; i>=0 && maze[i][j] == ' '; --i) Traverse(maze, cnt, i, j);
    for(i=row+1, j=column; i<cnt && maze[i][j] == ' '; ++i) Traverse(maze, cnt, i, j);
    return;
}
int main()
{

    char maze[32][82], end[82], *str;
    int n, i, j, row, column, flag, cnt, len;
    scanf("%d", &n);
    getchar();
    while(n--)
    {
        cnt = len = 0;
        str == NULL;
        while(fgets(maze[cnt], 82, stdin) != NULL)
        {
            len = strlen(maze[cnt]);
            if(maze[cnt][len-1] == '\n') maze[cnt][len-1] = '\0';
            else maze[cnt][len] = '\0';
            if((str = strchr(maze[cnt], '*')) != NULL)
            {
                row = cnt;
                column = str - maze[cnt];
                maze[row][column] = '#';
            }
            if(maze[cnt][0] == '_') break;
            else cnt++;
        }
        Traverse(maze, cnt, row, column);
        for(i=0; i<=cnt; ++i)
        {
            printf("%s\n", maze[i]);
        }
        
    }
    return 0;
}

 

posted @ 2013-03-28 21:34  Gifur  阅读(423)  评论(0编辑  收藏  举报
TOP