Fork me on GitHub

Uva 572 - Oil Deposits(DFS)

  Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

Sample Output 

0
1
2
2

 

 


Miguel A. Revilla 
1998-03-10
 
 
复制代码
#include<stdio.h>
#include<string.h>
#define MAXN 120

void dfs(char (*alpha)[MAXN], int row, int column, int n, int m)
{
    int i, j;
    for(j=column-1; j>=0 && alpha[row][j] == '@'; --j)
    {
        alpha[row][j] = '*';
        dfs(alpha, row, j, n, m);
    }
    for(j=column+1; j<n && alpha[row][j] == '@'; ++j) 
    {
        alpha[row][j] = '*';
        dfs(alpha, row, j, n, m);    
    }
    
    for(i=row-1; i>=0 && alpha[i][column] == '@'; --i)
    {
        alpha[i][column] = '*';
        dfs(alpha, i, column, n, m);
    }
    for(i=row+1; i<m && alpha[i][column] == '@'; ++i)
    {
        alpha[i][column] = '*';
        dfs(alpha, i, column, n, m);
    }
    
    for(i=row+1, j=column-1; i<m && j>=0 && alpha[i][j] == '@'; ++i, --j)
    {
        alpha[i][j] = '*';
        dfs(alpha, i, j, n, m);
    }
    for(i=row+1, j=column+1; i<m && j<n && alpha[i][j] == '@'; ++j, ++i)
    {
        alpha[i][j] = '*';
        dfs(alpha, i, j, n, m);
    }
    
    for(i=row-1, j=column-1; i>=0 && j>=0 && alpha[i][j] == '@'; --i, --j)
    {
        alpha[i][j] = '*';
        dfs(alpha, i, j, n, m);
    }
    for(i=row-1, j=column+1; i>=0 && j<n && alpha[i][j] == '@'; --i, ++j)
    {
        alpha[i][j] = '*';
        dfs(alpha, i, j, n, m);
    }
    
    return;
}

int main()
{
    int m, n, cnt, i, j;
    char alpha[MAXN][MAXN];
    while(scanf("%d%d", &m, &n) != EOF && m)
    {
        getchar();
        for(i=0; i<m; ++i)
            {
                for(j=0; j<n; ++j)
                scanf("%c", &alpha[i][j]);
                getchar();
            }
            cnt = 0;
        for(i=0; i<m; ++i)
            for(j=0; j<n; ++j)
            {
                if(alpha[i][j] == '@')
                {
                    cnt++;
                    dfs(alpha, i, j, n, m);
                }    
            }
        printf("%d\n", cnt);
    }
    return 0;
}
复制代码

解题思路:

AC率很高这题,思路就不必再遨述了。属于深度优先查找的问题,代码还是不够简得继续学习

posted @   Gifur  阅读(349)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示