Fork me on GitHub

Uva 375 - Inscribed Circles and Isosceles Triangles

Inscribed Circles and Isosceles Triangles 

Given two real numbers

 

B
the width of the base of an isosceles triangle in inches
H
the altitude of the same isosceles triangle in inches

 

Compute to six significant decimal places

 

C
the sum of the circumferences of a series of inscribed circles stacked one on top of another from the base to the peak; such that the lowest inscribed circle is tangent to the base and the two sides and the next higher inscribed circle is tangent to the lowest inscribed circle and the two sides, etc. In order to keep the time required to compute the result within reasonable bounds, you may limit the radius of the smallest inscribed circle in the stack to a single precision floating point value of 0.000001.

 

For those whose geometry and trigonometry are a bit rusty, the center of an inscribed circle is at the point of intersection of the three angular bisectors.

 

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input will be a single line of text containing two positive single precision real numbers (B H) separated by spaces.

 

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output should be a single real number with twelve significant digits, six of which follow the decimal point. The decimal point must be printed in column 7.

 

Sample Input

1

0.263451 0.263451

Sample Output

     0.827648

复制代码
#include<stdio.h>
#include<math.h>
int main()
{

    double b, h, l, sum, temp, r ;
    double Pl = acos(-1.0); // 其实我只知道别人是用这个的,我AC前用3.14159265358都是WA呀 
    int T;
    scanf("%d", &T);
    while(T--)
    {
        sum = l = r = 0;
        scanf("%lf%lf", &b, &h);
        while(1)
        {
            l = atan(h/(b/2));
            r = tan(l/2)*b/2;
            if(r < 0.000001) break;
            sum += 2*r*Pl;
            b = b*(h-2*r)/h, h = h - 2*r;
        }
        
        printf("%13.6lf\n", sum);
        if(T != 0) printf("\n");
    }
    return 0;
}
复制代码

解题报告:

其实这题我不想写题解的,一是因为它简单,二是一个Pi的声明也用了我几个WA,但想到做人还是有始有终才行,所以……

posted @   Gifur  阅读(561)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示