Fork me on GitHub

Uva 350 - Pseudo-Random Numbers

Pseudo-Random Numbers 

Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be really random. Random numbers are used in many applications, including simulation.

 

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( tex2html_wrap_inline32 , where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed) is 4, then we can determine the next few pseudo-random numbers are follows:

 

tabular21

 

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by the modulus, M.

 

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

 

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be less than M.

 

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

 

Sample Input

 

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

 

Sample Output

 

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220

复制代码
#include<stdio.h>
#include<string.h>
#define MAXN 10000
int cycle[MAXN];
int judge[MAXN];
int main()
{

    int i, temp, base, n, step, mod, cnt, k, T = 0;
    while(scanf("%d%d%d%d", &base, &step, &mod, &n) != EOF)
    {
        if(base+n+step+mod == 0) break;  // sign for end of input
        
        memset(cycle, 0, sizeof(cycle)); //initialization
        memset(judge, 0, sizeof(judge));
        
        for(cnt=0,temp=n; cnt < MAXN && judge[temp] == 0; ++cnt)
        {// find the same digit and record the forehead number
            judge[temp] = 1, cycle[cnt] = temp;
            temp = (base*temp + step) % mod;
        }
        printf("Case %d: ", ++T);
        if(temp != n) 
        {// if the aim number is not the first one
            k = 0;
            while(temp != cycle[++k]);
            printf("%d\n", cnt-k);
        }
        else printf("%d\n", cnt);
    }
    
    return 0;
}
复制代码

解题思路:

跟上面一题差不多,有上一题的经验,就不用怕开的数组会超内存或者超时了,所以还是一样的遍历,终止的信号是之前出现同样的数字,后面也要注意开始的那一个数不一定就是后面相等的数

PS:完全不在状态啊,没有把重定向删掉导致了一次不必要的WA

posted @   Gifur  阅读(735)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示