Fork me on GitHub

Uva 10110 - Light, more light

Light, more light

The Problem

There is man named "mabu" for switching on-off light in our University. He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption (or may be he is mad or something else) he does a peculiar thing. If in a corridor there is `n' bulbs, he walks along the corridor back and forth `n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position. A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off? 
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less then or equals 2^32-1. A zero indicates the end of input. You should not process this input.

The Output

Output "yes" if the light is on otherwise "no" , in a single line.

Sample Input

3
6241
8191
0

Sample Output

no
yes
no

Sadi Khan 
Suman Mahbub 
01-04-2001

 

复制代码
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    long long n, m;
    while(cin>>n)
    {
        if(n == 0) break;
        m = (long long)sqrt(n);
        if(m*m == n) cout<<"yes"<<endl;
        else cout<<"no"<<endl;
    }
    return 0;
}
复制代码

解题思路:

从测试数据可以看出,刚开始灯都是关着的状态,如果对其操作了偶数次,那么最后还是关着的状态,此刻应该输出no,那么能整除它的数的个数是几还是偶,那就要看它是不是完全平方数了,因为如果它是完全平方数,那么开根出来的那个数由于没有跟它对应的那个数,那么这就说明能整除这个完全平方数的个数是奇数,此刻就达到了灯开着的要求了,此刻输出“yes”

 

posted @   Gifur  阅读(433)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示