Fork me on GitHub

Uva 10014 - Simple calculations

 Simple calculations 

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <=  ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci   for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line.

For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.

Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1

1
50.50
25.50
10.15

Sample Output

27.85


复制代码
#include<stdio.h>
#include<string.h>

int main()
{
    int T, n, i;
    double first, final, sum, temp, ans;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        scanf("%lf", &first);
        scanf("%lf", &final);
        for(i=1,sum=0; i<=n; ++i)
        {
            scanf("%lf", &temp);
            sum += 2.0*(n+1-i)*temp;
        }
        
        ans = n*first+final-sum;
        printf("%.2lf\n", ans/(n+1));
        
        if(T != 0) printf("\n");
    }
    return 0;
}
复制代码

 

posted @   Gifur  阅读(641)  评论(0编辑  收藏  举报
编辑推荐:
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
阅读排行:
· 阿里最新开源QwQ-32B,效果媲美deepseek-r1满血版,部署成本又又又降低了!
· 单线程的Redis速度为什么快?
· SQL Server 2025 AI相关能力初探
· 展开说说关于C#中ORM框架的用法!
· AI编程工具终极对决:字节Trae VS Cursor,谁才是开发者新宠?
TOP
点击右上角即可分享
微信分享提示