Fork me on GitHub

Uva 621 - Secret Research

Secret Research 

At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:

 


`positive result', `negative result', `experiment failed' or `experiment not completed'

 


The encrypted result constitutes a string of digits S, which may take one of the following forms:

 


$\bullet$
positive result 		 S = 1 or S = 4 or S = 78 
$\bullet$
negative result 		 S = S35 
$\bullet$
experiment failed 		 S = 9S4 
$\bullet$
experiment not completed 		 S = 190S

(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)

 


You are to write a program which decrypts given sequences of digits.

 

Input 

A integer n stating the number of encrypted results and then consecutive n lines, each containing a sequence of digits given as ASCII strings.

 

Output 

For each analysed sequence of digits the following lines should be sent to output (in separate lines):

 


		 + 		  for a positive result
		 - 		  for a negative result
		 * 		  for a failed experiment
		 ? 		  for a not completed experiment

In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.

 

Sample Input 

 

4
78
7835
19078
944

 

Sample Output 

+
-
?
*

 

 


Miguel A. Revilla 
2000-01-10
 
 
 
复制代码
#include<stdio.h>
#include<string.h>

char s[1002];

int main()
{
    int n, len;
    scanf("%d", &n);
    while(n--)
    {
        scanf("%s", s);
        len = strlen(s);
        if(strcmp(s, "1") == 0 || strcmp(s, "4") == 0 || strcmp(s, "78") == 0)
            printf("+\n");
        else if(s[len-1] == '5' && s[len-2] == '3') 
            printf("-\n");
        else if(s[0] == '9' && s[len-1] == '4')
            printf("*\n");
        else if(strstr(s, "190") != NULL && strstr(s, "190") - s == 0)
            printf("?\n");
    } 
    return 0;
}
复制代码

解题思路:

我对这题感到无语,看题目就纠结了我很久了:

(个人观点)

1〉开始没有较为醒目的提示说明只能符合这四种情况的S,

2>中间括号对 S35 的解释表示不理解

3>在Output中最后一条语句表示不理解

posted @   Gifur  阅读(414)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示