Fork me on GitHub

Uva 400 - Unix ls

Unix ls 

The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the ls function.

 

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to right.

 

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer ( tex2html_wrap_inline41 ). There will then be N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to zA to Z, and 0 to 9) and from the following set { ._- } (not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

 

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

 

Sample Input

 

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben

 

Sample Output

 

------------------------------------------------------------
12345678.123         size-1               
2short4me            size2                
mid_size_name        size3                
much_longer_name     tiny                 
shorter              very_long_file_name  
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky          
Buckwheat      Darla          Mrs_Crabapple  Stimey         
Butch          Froggy         P.D.           Weaser         
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben       
Bobby       Cindy       Jody        Mike        Shirley     
Buffy       Danny       Keith       Mr._French  Sissy       
Carol       Greg        Lori        Peter


复制代码
#include<stdio.h>
#include<string.h>
#include<math.h>
char list[200][100];

int minusline(int len)
{//计算需要多少列,函数返回列数 
    double minus = len+2;
    int n;
    n = (int)floor(62*1.0/minus);
    return n;
}

int main()
{
    int i, j, len, k, n, m, flag, longest, row, column, T=0;
    char temp[100];
    while(scanf("%d", &n) != EOF)
    {
        if(T++ != 0) printf("\n");
        for(i=0,longest=0; i<n; ++i)
        {
            scanf("%s", temp);
            len =strlen(temp);  // 计算最长字符串的长度 
            if(len > longest) longest = len;
            strcpy(list[i], temp);
        }
        
        for(i=0; i<n-1; i++)
        {// 排序 
            flag = 1;
            for(j=0; j<n-1-i; ++j)
            {
                if(strcmp(list[j], list[j+1]) > 0)
                {
                    strcpy(temp, list[j]);
                    strcpy(list[j], list[j+1]);
                    strcpy(list[j+1], temp);
                    flag = 0;
                }
            }
            if(flag) break;
        }
        
        column = minusline(longest);
        for(i=0; i<60; i++) printf("-");
        printf("\n");
        row = n%column ? n/column+1 : n/column; // 计算行数 

        for(i=0; i<row; ++i)
        {
            for(j=0; j<column; ++j)
            {
                if(i+row*j >= n) break;
                printf("%s", list[i+row*j]);
                // 纠结于空格的输出 
                m = j != column-1 ? 2 : 0;
                len = strlen(list[i+row*j]);
                for(k=0; k<longest-len+m; ++k)
                printf(" ");
            }
            if(i != row-1) printf("\n");
        }
    }
    return 0;
}
复制代码

 

解题报告:

题目的说明跟Sample Output并不符合,AC得到的结果如下:

复制代码
------------------------------------------------------------
12345678.123         size-1               
2short4me            size2                
mid_size_name        size3                
much_longer_name     tiny                 
shorter              very_long_file_name  
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky          
Buckwheat      Darla          Mrs_Crabapple  Stimey         
Butch          Froggy         P.D.           Weaser         
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben       
Bobby       Cindy       Jody        Mike        Shirley     
Buffy       Danny       Keith       Mr._French  Sissy       
Carol       Greg        Lori        Peter       
复制代码

 

 



posted @   Gifur  阅读(259)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示