Fork me on GitHub

Uva 10115 - Automatic Editing

Problem E: Automatic Editing

Source file: autoedit.{ccppjavapas}
Input file: autoedit.in
Output file: autoedit.out

Text-processing tools like awk and sed allow you to automatically perform a sequence of editing operations based on a script. For this problem we consider the specific case in which we want to perform a series of string replacements, within a single line of text, based on a fixed set of rules. Each rule specifies the string to find, and the string to replace it with, as shown below.

 

Rule Find Replace-by
1. ban bab
2. baba be
3. ana any
4. ba b hind the g

 

To perform the edits for a given line of text, start with the first rule. Replace the first occurrence of the find string within the text by the replace-by string, then try to perform the same replacement again on the new text. Continue until the find string no longer occurs within the text, and then move on to the next rule. Continue until all the rules have been considered. Note that (1) when searching for a find string, you always start searching at the beginning of the text, (2) once you have finished using a rule (because thefind string no longer occurs) you never use that rule again, and (3) case is significant.

For example, suppose we start with the line

 

banana boat

 

and apply these rules. The sequence of transformations is shown below, where occurrences of a find string are underlined and replacements are boldfaced. Note that rule 1 was used twice, then rule 2 was used once, then rule 3 was used zero times, and then rule 4 was used once.

 

  Before After
  banana boat babana boat
  babana boat bababa boat
  bababa boat beba boat
  beba boat behind the goat

 

The input contains one or more test cases, followed by a line containing only 0 (zero) that signals the end of the file. Each test case begins with a line containing the number of rules, which will be between 1 and 10. Each rule is specified by a pair of lines, where the first line is the find string and the second line is the replace-by string. Following all the rules is a line containing the text to edit. For each test case, output a line containing the final edited text.

Both find and replace-by strings will be at most 80 characters long. Find strings will contain at least one character, but replace-by strings may be empty (indicated in the input file by an empty line). During the edit process the text may grow as large as 255 characters, but the final output text will be less than 80 characters long.

The first test case in the sample input below corresponds to the example shown above.

Example input:

4
ban
bab
baba
be
ana
any
ba b
hind the g
banana boat
1
t
sh
toe or top
0

 

Example output:

behind the goat
shoe or shop

 

复制代码
#include<stdio.h>
#include<string.h>

int deal(char *temp)
{// 根据fgets的特性,处理掉字符串后缀的回车符,并注意只有一个回车的情况,即题目要求说的无替代的情况 
    int len = strlen(temp);
    if(temp[0] != '\n')
    {
        if(temp[len-1] == '\n') temp[len-1] = '\0';
    }
    else temp[1] = '\0';
    return 0;
}

int main()
{
    char find[12][84], replace[12][84], text[260], temp[260], *str;
    int i, j, t, n, m, cnt;
    while(scanf("%d", &n) != EOF && n)
    {
        getchar();
        memset(text, 0, sizeof(text));
        memset(temp, 0, sizeof(temp));
        for(i=0; i<n; ++i) {fgets(find[i], 84, stdin); deal(find[i]); fgets(replace[i], 84, stdin); deal(replace[i]);}
        fgets(text, 260, stdin); deal(text);
        for(i=0; i<n; ++i)
        {
            cnt = strlen(find[i]) > strlen(replace[i]) ? strlen(find[i]) : strlen(replace[i]);
            while((str = strstr(text, find[i])) != NULL)
            {// 题目要求:直到特定的rule没有可以替代的为止,退出while循环 
                t = str - text;
                if(t != 0)  // if-else 处理替代的位置是否为开头,分情况讨论 
                {
                    memcpy(temp, text, t*sizeof(char));  // 注意使用memcpy函数和其与strcpy函数的区别 
                    if(replace[i][0] != '\n')
                    {
                        strcpy(temp+t, replace[i]);
                    }
                    else temp[t] = '\0'; //只是删除不替代的情况,上面deal函数有提到
                    strcat(temp, text+t+strlen(find[i]));
                    strcpy(text, temp);
                }
                else
                {
                    if(replace[i][0] != '\n')
                    { 
                        strcpy(temp, replace[i]);
                        strcat(temp, text+strlen(find[i]));  //蛋疼的就是找之间的关系 
                    }
                    else strcpy(temp, text+strlen(find[i]));  //只是删除不替代的情况,上面deal函数有提到
                    strcpy(text, temp);
                }
                memset(temp, 0, sizeof(temp));
            }
        }
        printf("%s\n", text);
        memset(text, 0, sizeof(text));
    }
    return 0;
}

//  
复制代码

解题报告:

1y,没想到的事情,但还是花了不少时间,特别在找text 和 temp 的关系时,何时复制过去,复制到哪部分。

 

 

 
posted @   Gifur  阅读(335)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示