Fork me on GitHub

HDU ACM 1213 How Many Tables(UFS)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7430    Accepted Submission(s): 3574


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

 

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 

 

Sample Output
2 4
 

 

Author
Ignatius.L
 

 

Source
 

 

Recommend
Eddy
 
复制代码
#include<stdio.h>
#include<string.h>
int father[1002];

int find(int n)
{
    if(father[n] == n) return n;
    else return father[n] = find(father[n]);
}

int main()
{
    int n, m, T, x, y, cnt, i, j;
    scanf("%d", &T);
    while(T--)
    {
        cnt = 0;
        scanf("%d%d", &n, &m);
        for(i=0; i<n; ++i) father[i] = i;
        for(i=0; i<m; ++i) 
        {
            scanf("%d%d", &x, &y);
            x = find(x-1), y = find(y-1);
            if(x != y) father[x] = y;
        }
        for(i=0; i<n; ++i) if(father[i] == i) cnt++;
        printf("%d\n", cnt);
    }
    return 0;
}
复制代码

 

posted @   Gifur  阅读(1282)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示