Fork me on GitHub

Uva 10474 - Where is the Marble?(水题)

Where is the Marble? 

Time limit: 3.000 seconds

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

 

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

 

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

 

  • `x found at y', if the first marble with number x was found at position y. Positions are numbered 1, 2,...,N.
  • `x not found', if the marble with number x is not present.

Look at the output for sample input for details.

 

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

 

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

 

 


Problem-setter: Monirul Hasan Tomal, Southeast University
 
复制代码
#include<stdio.h>
#include<string.h>

int Marble[10020];

int main()
{
    int n, q, i, j, loc, num, flag, T=0;
    while(scanf("%d%d", &n, &q) == 2 &&n && q)
    {
        memset(Marble, 0, sizeof(Marble));
        for(i=0; i<n; ++i)
        scanf("%d", &Marble[i]);
        for(i=0; i<n-1; ++i)
        {
            flag = 0;
            for(j=0; j<n-1-i; ++j)
            {
                if(Marble[j] > Marble[j+1])
                {
                    loc = Marble[j];
                    Marble[j] = Marble[j+1];
                    Marble[j+1] = loc;
                    flag = 1;
                }
            }
            if(!flag) break; 
        }
        printf("CASE# %d:\n", ++T);
        for(i=1; i<=q; ++i)
        {
            scanf("%d", &num);
            for(j=0; j<n && Marble[j] != num; ++j);
            if(j>=n) printf("%d not found\n", num);
            else printf("%d found at %d\n", num, j+1);
        }
    }
    return 0;
} 
复制代码

解题报告:

这感觉不怎么好受,知道它需要的是什么,自己却投机取巧。

 

 

posted @   Gifur  阅读(278)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示