Fork me on GitHub

Uva 133 - The Dole Queue

The Dole Queue 

Time limit: 3.000 seconds

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

 

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

 

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

 

Sample input

 

10 4 3
0 0 0

 

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.

 

复制代码
#include<stdio.h>
#include<string.h>

int main()
{
    int queue[22], i, j, n, t, k, m, front, rear;
    
    while(scanf("%d%d%d", &n, &k ,&m) == 3 && n && m && k)
{
    
    memset(queue, 0, sizeof(queue));
    for(i=1; i<=n; ++i) queue[i] = i;
    t = 0;
    front = 0, rear = n;
    while(t<n)
    {
        if(t) printf(",");
        i = j = 0;
        while(!queue[front]) {front++; front = front%n ? front%n : n;}
        while(!queue[rear]) {rear--; rear = rear <= 0 ? n : rear;}
             while(i<k)
             {
                 if(queue[(front = front%n? front%n: n)]) i++;
                 if(i >= k) continue; 
                 front = front%n+1;
                  
             }
             while(j<m)
             {
                 if(queue[(rear = rear%n ? rear%n : n)]) j++;
                 if(j >= m) continue;
                 rear = rear - 1 ? rear - 1 : n;
             }
         printf("%3d", queue[front]); queue[front] = 0; t++;
         if(front != rear) {printf("%3d", queue[rear]); queue[rear] = 0; t++;} 
    }
    printf("\n");
    
}
    return 0;
}
复制代码

 

解题报告:

1是要注意格式,而是要明白整个流程 counter-clockwise是逆时针的意思,模拟一次很多问题都解决了, 当第一个applicant挑中时,他并有及时离开,而是参加了第二个applicant的挑选,所以也就有了后来只挑到一个applicant的原因,而且不管是哪个office挑到applicant,总要及时的指向下一个applicant, 这个问题有点像约瑟夫环的问题

posted @   Gifur  阅读(1000)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示