Fork me on GitHub

Uva 10815 - Andy's First Dictionary

Problem B: Andy's First Dictionary

Time limit: 3 seconds


Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

 

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

 

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

 

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

 

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

 


Joke and image taken from the Web
 
复制代码
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char word[5004][204];
char input[204], temp[204];
int main()
{
    int i, j, T = 0, len, count, flag;
    for(i=0; i<5004; ++i)    memset(word[i], '\0', sizeof(char)*204);
    
    memset(input, '\0', sizeof(char)*204);
    memset(temp, '\0', sizeof(char)*204);
    while(fgets(input, 204, stdin) != NULL)
    {
        flag = count = 0;
        len = strlen(input);
        if(input[len-1] != '\n') input[len++] = '\n';
        for(i=0; i<len; ++i)
        {
            if(isalpha(input[i]) && isupper(input[i])) input[i] =  tolower(input[i]);
            
            if(isalpha(input[i])) 
            {
                temp[count++] = input[i];
                flag = 1;
            }
            else if(flag)
            {
                flag = 0;
                if(!T) {strcpy(word[T], temp); memset(temp, '\0', sizeof(char)*204); T++;}
                else 
                {
                    for(j=0; j<T && strcmp(word[j], temp) != 0; ++j); 
                    if(j >= T) strcpy(word[T++], temp);
                    memset(temp, '\0', sizeof(char)*204);    
                }
                count = 0;
            }
        }
        
        memset(input, '\0', sizeof(char)*204);
        memset(temp, '\0', sizeof(char)*204);
    }
    
    for(i=0; i<T-1; ++i)
    {
        flag = 1;
        for(j=0; j<T-1-i; ++j)
        if(strcmp(word[j], word[j+1]) > 0)
        {
            strcpy(temp, word[j]);
            strcpy(word[j], word[j+1]);
            strcpy(word[j+1], temp);
        }
    }
    for(i=0; i<T; ++i)
    printf("%s\n", word[i]);
    return 0;
}
复制代码


解题报告:

判断单词,处理大小写,判断是否重复,单词按字典顺序排序

 
 
posted @   Gifur  阅读(361)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示