Fork me on GitHub

Uva 537 - Artificial Intelligence?

 Artificial Intelligence? 

Time limit: 3.000 seconds

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

 


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

 

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

 

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

 

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and UP and I, or U and I will be given.

 

Output 

For each test case, print three lines:

 

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

 

Sample Input 

 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

 

Sample Output 

 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

 

 


Miguel A. Revilla 
1999-01-11
 
 
复制代码
#include<stdio.h>
#include<string.h>
#include<ctype.h>
char test[1020];

int main()
{
    int t, T, i, j, doc1, doc2, flag, len;
    double res, n, m, e;
    char ch;
    scanf("%d", &T);
    getchar();
    for(t=1; t<=T; ++t)
    {
        n = m = res = 0;
        len = doc1 = doc2 = 0;
        memset(test, '\0', sizeof(test));
        fgets(test, 1020, stdin);
        len = strlen(test);
        doc2 = strchr(test+(doc1 = strchr(test, '=') - test)+1, '=') - test;
        flag = 0, e = 1;
        for(i=doc1+1;  isdigit(test[i]) || test[i] == '.';  ++i)
        {
            if(isdigit(test[i]))
            {
                if(!flag)    n = n*10 + (test[i] - '0');
                else{
                    e /= 10;
                    n += e*(test[i] - '0');
                }
            }
            else if(test[i] == '.')    flag = 1;
        }
        if(test[i] == 'M') n *= 1000000;
        else if(test[i] == 'k') n *= 1000;
        else if(test[i] == 'm') n /= 1000;
      
        flag = 0, e = 1;
        for(i=doc2+1;  isdigit(test[i]) || test[i] == '.';  ++i)
        {
            if(isdigit(test[i]))
            {
                if(!flag)    m = m*10 + (test[i] - '0');
                else{
                    e /= 10;
                    m += e*(test[i] - '0');
                }
            }
            else if(test[i] == '.')    flag = 1;
        }
        if(test[i] == 'M') m *= 1000000;
        else if(test[i] == 'k') m *= 1000;
        else if(test[i] == 'm') m /= 1000;
        
        printf("Problem #%d\n", t);
        if(test[doc1-1] == 'P')
        {
            if(test[doc2-1] == 'U') printf("I=%.2lfA\n", n/m);
            else printf("U=%.2lfV\n", n/m);
        }
        else if(test[doc2-1] == 'P')
        {
            if(test[doc1-1] == 'U') printf("I=%.2lfA\n", m/n);
            else printf("U=%.2lfV\n", m/n);
        }
        else printf("P=%.2lfW\n", n*m);
        printf("\n");
    } 
    return 0;
}
复制代码

 

解题报告:

题目很简单(ture but sad)这句话很简单的阐明了这道物理题目,找出两个等号的位置,判定各个物理量,处理数据的大小(包括小数点的检查判定) 同时也要注意符号M, m, k, A, U, W

posted @   Gifur  阅读(296)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示