Fork me on GitHub

HD ACM 1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19870    Accepted Submission(s): 7659

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.

 

Sample Input
2
3
4
 
Sample Output
7
6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
Author
Ignatius.L
 
复制代码
#include<stdio.h>
#include<string.h>
int main()
{
    int ans, n, m, i, j, t, circle[100];
    scanf("%d", &m);
    for(i=1; i<=m; ++i)
    {
        memset(circle, 0, sizeof(circle));
        scanf("%d", &n);
        circle[0] = n%10;
        for(j=1; j<100; ++j)
        {
            circle[j] = (circle[j-1]*(n%10))%10;
            if(circle[0] == circle[j]) break;
        }
        
        if(n%j == 0) printf("%d\n", circle[j-1]);
        else printf("%d\n", circle[n%j - 1]);
    }
    return 0;
}
复制代码

解题报告:

各种水,天知道我上辈子欠了谁,2WA,原因是没有注意到溢出,可是这题做过啊!

 
posted @   Gifur  阅读(698)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示