Fork me on GitHub

HDU ACM 1032 The 3n + 1 problem

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13870    Accepted Submission(s): 5095

Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.
 
Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no opperation overflows a 32-bit integer.
 
Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
 
Sample Input
1 10 100 200 201 210 900 1000
 

Sample Output

1 10 20 100 200 125 201 210 89 900 1000 174
 
Source
 
Recommend
mcqsmall
 
复制代码
#include<stdio.h>
int collatz(int A, int &terms)
{
    ++terms;
    if(A == 1)  return 0;
    else if(A%2 == 0) collatz(A/2, terms);
    else collatz(3*A+1, terms);
}

int main()
{
    int terms, t, count = 0, max = 0, i, j, tempi, tempj;
    while(scanf("%d%d", &i, &j) != EOF)
    {
        tempi = i; tempj = j;
        if(i>j)    {max = i; i = j; j = max;}
        max = 0;
        for(t=i; t<=j; ++t)
        {
            terms = 0;
            collatz(t, terms);
            max = max>=terms? max:terms;
        }
        printf("%d %d %d\n", tempi, tempj, max);
    }
    return 0;
}
复制代码

解题报告:

个今天把这题放进Vegetable中是有原因的,为何思维总是如此的固定,打破僵局的最好的方法或者说训练是什么呢? 记住这题WA的原因:少考虑到i〉j的可能,如果考虑到了你也知道了output中所说的那句话的意思。

2/4  AC/WA

 
posted @   Gifur  阅读(188)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示