Fork me on GitHub

UVa 401 - Palindromes

  Palindromes 

Time limit: 3.000 seconds

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

 


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E"are each others' reverses.

 


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y"are all their own reverses.

 


A list of all valid characters and their reverses is as follows.

 

 

Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    

 

 


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

 

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

 

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

 

 

STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

 

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

 

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.

 

 


Miguel Revilla 2001-04-16
 
 
复制代码
#include<stdio.h>
#include<string.h>

int is_repalindrome(char s[])
{
    int i, j, len;
    len = strlen(s);
    for(j=len/2, i = len%2 != 0? (len/2) : (len/2-1); i>=0&&j<len; --i, ++j)
    if(s[i] != s[j]) break;
    if(i<0) return 1;
    else return 0;
}

int is_mirrored(char s[])
{
    int i, j, len, t;
    char test[] = "AHIMO0TUVWXY18";
    len = strlen(s);
    for(j=len/2, i = len%2 != 0? (len/2) : (len/2-1); i>=0&&j<len; --i, ++j)
    {
        if(s[j] == s[i])
        {
            for(t=0; t<14; ++t) if(test[t] == s[j]) break;
            if(t >= 14) return 0;
        }
        else if((s[j] == '0' || s[j] == 'o') && s[i] == 'o' || s[i] == '0');
        else 
        {
            switch(s[i])
            {
                
            case 'E': if(s[j] != '3') return 0;
                      else break;
               case '3': if(s[j] != 'E') return 0;
                      else break;
              case 'J': if(s[j] != 'L') return 0;
                      else break;
             case 'L': if(s[j] != 'J') return 0;
                      else break;
            case 'S': if(s[j] != '2') return 0;
                      else break;
               case '2': if(s[j] != 'S') return 0;
                      else break;
              case 'Z': if(s[j] != '5') return 0;
                      else break;
              case '5': if(s[j] != 'Z') return 0;
                      else break;
            default : return 0;
          
            }              
        }
    }
    return 1;

}


int main()
{
    char s[101];
    int flag1 = 0, flag2 = 0, count = 0;
    memset(s, 0, sizeof(s));
    while(scanf("%s", s) != EOF)
    {
        getchar();
        flag1 = is_repalindrome(s);
        flag2 = is_mirrored(s);    
        switch(flag1)
        {
            case 0: if(!flag2) printf("%s -- is not a palindrome.\n", s);
                    else printf("%s -- is a mirrored string.\n", s);
                    break;
            case 1: if(!flag2) printf("%s -- is a regular palindrome.\n", s);
                    else printf("%s -- is a mirrored palindrome.\n", s);
                    break;
            default: return 0;
        }
         printf("\n");
        memset(s, 0, sizeof(s));
    }
    return 0;
}
复制代码

 

结题报告:

4WA 1AC WA的原因不少,题目长但题意很简单,只是两个特殊的字符串的判断,WA的原因恐怕没人会相信,将变量i写成t,将大写字母O写成小写o,switch语句中少写了break,导致的结果是花时间调试了大半天,输出时多加了"--',后来检查输出才发现,汗颜!

posted @   Gifur  阅读(250)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示