Fork me on GitHub

UVa 694 - The Collatz Sequence

  The Collatz Sequence 

Time limit: 3.000 seconds

An algorithm given by Lothar Collatz produces sequences of integers, and is described as follows:

Step 1:
Choose an arbitrary positive integer A as the first item in the sequence.
Step 2:
If A = 1 then stop.
Step 3:
If A is even, then replace A by A / 2 and go to step 2.
Step 4:
If A is odd, then replace A by 3 * A + 1 and go to step 2.

It has been shown that this algorithm will always stop (in step 2) for initial values of A as large as 109, but some values of A encountered in the sequence may exceed the size of an integer on many computers. In this problem we want to determine the length of the sequence that includes all values produced until either the algorithm stops (in step 2), or a value larger than some specified limit would be produced (in step 4).

 

Input 

The input for this problem consists of multiple test cases. For each case, the input contains a single line with two positive integers, the first giving the initial value of A (for step 1) and the second giving L, the limiting value for terms in the sequence. Neither of these, A or L, is larger than 2,147,483,647 (the largest value that can be stored in a 32-bit signed integer). The initial value of A is always less than L. A line that contains two negative integers follows the last case.

 

Output 

For each input case display the case number (sequentially numbered starting with 1), a colon, the initial value for A, the limiting value L, and the number of terms computed.

 

Sample Input 

 

 3 100
 34 100
 75 250
 27 2147483647
 101 304
 101 303
 -1 -1

 

Sample Output 

 Case 1: A = 3, limit = 100, number of terms = 8
 Case 2: A = 34, limit = 100, number of terms = 14
 Case 3: A = 75, limit = 250, number of terms = 3
 Case 4: A = 27, limit = 2147483647, number of terms = 112
 Case 5: A = 101, limit = 304, number of terms = 26
 Case 6: A = 101, limit = 303, number of terms = 1

 

 


Miguel Revilla 
2000-08-14
 
复制代码
#include<stdio.h>
int collatz(long A, long limit, long &terms)
{
    unsigned long long a = 3*A+1;
    ++terms;
    if(A == 1)     return 0;
    else if(A%2 == 0) collatz(A/2, limit, terms);
    else 
    {
        if(a > limit) return 0;
        else collatz(A*3+1, limit, terms);
    }
}

int main()
{
    long A, limit, terms, count = 0;
    while((scanf("%ld%ld", &A, &limit) != EOF) && A >= 0 && limit >=0)
    {
        terms = 0;
        collatz(A, limit, terms);
        printf("Case %ld: A = %ld, limit = %ld, number of terms = %ld\n", ++count, A, limit, terms);
    }
    return 0;
}
复制代码

 

解题报告:

1A,主要是看是否掌握递归简单的思想,代码编写的过程出现了很多的小错误,列举说:求模写成了求商整数,即把%写成了/,二是输出的时候少

加一个变量,会开始用断言(assert),不过代码中出现的错误还是通过printf出中间值找出来的

posted @   Gifur  阅读(207)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示