Fork me on GitHub

HDU ACM 1097 Hard Puzzle

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19595    Accepted Submission(s): 7003

Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800
Sample Output
9
6
Author
eddy
Recommend
JGShining
 
 AC代码:
复制代码
#include<stdio.h>
#include<string.h>
int temp[100];
int main()
{
    long i, n = 1, m;
    long long a, c;
    while(scanf("%lld%lld", &a, &c) != EOF)
    {
        memset(temp, 0, sizeof(temp));
        temp[0] = a%10;
        for(i=1; i<100; i++)
        {
            if((temp[i] = (temp[0]*temp[i-1])%10) == temp[0]) break;

        }
        printf("%d\n", temp[(c-1)%i]);
    }
    return 0;
}
复制代码

结题报告:

实话实说,很久没编程的感觉就连ACM Step中简单的题目都忘了如何做了,似乎以前做过的题今天拿出来好似未曾相见。WA了差不多一个晚上,弄坏了心情最后什么都做不了!

本是不属于这一路的人,当初的选择没说过要后悔!

 

 
posted @   Gifur  阅读(172)  评论(0编辑  收藏  举报
编辑推荐:
· 如何编写易于单元测试的代码
· 10年+ .NET Coder 心语,封装的思维:从隐藏、稳定开始理解其本质意义
· .NET Core 中如何实现缓存的预热?
· 从 HTTP 原因短语缺失研究 HTTP/2 和 HTTP/3 的设计差异
· AI与.NET技术实操系列:向量存储与相似性搜索在 .NET 中的实现
阅读排行:
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 分享 3 个 .NET 开源的文件压缩处理库,助力快速实现文件压缩解压功能!
· Ollama——大语言模型本地部署的极速利器
· DeepSeek如何颠覆传统软件测试?测试工程师会被淘汰吗?
TOP
点击右上角即可分享
微信分享提示