九度OJ 1001:A+B for Matrices

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:17682

解决:7079

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0
样例输出:
1
5
来源:
2011年浙江大学计算机及软件工程研究生机试真题

思路:

本题的意思是计算两个矩阵的和中, 全0行和全0列的个数。


代码:

#include <stdio.h>
 
#define N 10
 
int main(void)
{
    int m, n, i, j;
    int a[N][N], b[N][N];
 
    while (scanf("%d", &m) != EOF)
    {
        if (m == 0)
            break;
 
        scanf("%d", &n);
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                scanf("%d", &a[i][j]);
            }
        }
        int count = 0;
        for(i=0; i<m; i++)
        {
            int zerorow = 1;
            for(j=0; j<n; j++)
            {
                scanf("%d", &b[i][j]);
                a[i][j] += b[i][j];
                if (a[i][j] != 0)
                    zerorow = 0;
            }
            count += zerorow;
        }
        for(j=0; j<n; j++)
        {
            int zerocol = 1;
            for(i=0; i<m; i++)
            {
                if (a[i][j] != 0)
                    zerocol = 0;
            }
            count += zerocol;
        }
 
        printf("%d\n", count);
    }
 
    return 0;
}
/**************************************************************
    Problem: 1001
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


posted on 2015-10-14 22:03  梁山伯  阅读(152)  评论(0编辑  收藏  举报

导航