九度OJ 1143:Primary Arithmetic(初等数学) (进位)

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:616

解决:254

题目描述:

    Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty. 

输入:

    Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

输出:

    For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

样例输入:
123 456
555 555
123 594
0 0
样例输出:
NO carry operation.
3 carry operations.
1 carry operation.
来源:
2009年北京大学计算机研究生机试真题


思路:

求两数相加的进位次数。


代码:

#include<stdio.h>
int a,b;
int main()
{
        while(scanf("%d%d",&a,&b)!=EOF)
        {
                int c=0;
                int k=0;
                if(a==0&&b==0)
                        break;
                while(a!=0&&b!=0)
                {
                        c=(a%10+b%10+c)/10;
                        if(c>=1)
                                k++;
                        a/=10;
                        b/=10;
                }
                if(k==0)
                        printf("NO carry operation.\n");
                else if(k==1)
                        printf("%d carry operation.\n",k);
                else
                        printf("%d carry operations.\n",k);
        }
         
        return 0;
}
/**************************************************************
    Problem: 1143
    User: liangrx06
    Language: C
    Result: Accepted
    Time:0 ms
    Memory:912 kb
****************************************************************/


posted on 2015-10-24 12:37  梁山伯  阅读(305)  评论(0编辑  收藏  举报

导航