《挑战程序设计竞赛》2.3 动态规划-进阶 POJ1065 1631 3666 2392 2184(5)

POJ1065:
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3

代码

#include<iostream>
#include<algorithm>
using namespace std;

struct wood
{
    int l;
    int w;
    bool visited;
};

bool cmp(wood wood1, wood wood2)
{
    if(wood1.l < wood2.l)
        return true;
    if(wood1.l == wood2.l && wood1.w < wood2.w)
        return true;
    return false;
}

int main()
{
    int caseNum;
    cin >> caseNum;
    wood woods[5005];
    for(int mm = 0; mm<caseNum; mm++)
    {
        int woodNum;
        cin >> woodNum;


        for(int i=0; i<woodNum; i++)
        {
            cin >> (woods[i].l) >> woods[i].w;
            woods[i].visited = false;
        }

        sort(woods, woods + woodNum, cmp );

        int count = 0;
        for(int i=0; i<woodNum; i++)
        {
            if(woods[i].visited == false)
            {
                count++;
                woods[i].visited = true;
                int weight = woods[i].w;
                for(int j=i+1; j<woodNum; j++)
                {
                    if(woods[j].visited == true)
                        continue;
                    if(woods[j].l >= woods[i].l && woods[j].w >= weight)
                    {
                        woods[j].visited = true;
                        weight = woods[j].w;
                    }

                }
            }
        }
        cout << count << endl;
    }
    return 0;
}

posted on 2015-12-20 12:43  梁山伯  阅读(150)  评论(0编辑  收藏  举报

导航