Fractal

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
  • A box fractal of degree 1 is simply
    X
  • A box fractal of degree 2 is
    X X
    X
    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-



lengxia 's source code for C
Memory: 748 KB Time: 157 MS
Language: C++ Result: Accepted
#include <iostream>
#include<cmath>
using namespace std;
char a[730][730];

void p(int n,int x,int y)
{int p1,p2;
if(n==1)
a[x][y]='X';
else{

p1=2*pow(3.0,n-2);p2=pow(3.0,n-2);
p(n-1,x,y);       
    p(n-1,x,y+p1);       
    p(n-1,x+p2,y+p2);    
    p(n-1,x+p1,y);       
    p(n-1,x+p1,y+p1);
}

}



int main()
{
int n,i,j;

while(cin>>n,n!=-1)
{for(i=1;i<=pow(3.0,n-1);i++)
for(j=1;j<=pow(3.0,n-1);j++)
	a[i][j]='1';
	
	p(n,1,1);
for(i=1;i<=pow(3.0,n-1);i++)
{for(j=1;j<=pow(3.0,n-1);j++)
{if(a[i][j]=='1')cout<<" ";
else cout<<a[i][j];}
cout<<endl;
}
cout<<"-"<<endl;
}

return 0;}


FAQ | About Virtual Judge | Forum | Discuss | Open Source Project
All Copyright Reserved ©2010-2012 HUST ACM/ICPC TEAM
Anything about the OJ, please ask in the forum, or contact author:Isun
Server Time: 2014-07-16 15:25:22

posted @ 2014-07-16 15:25  冷夏的博客园  阅读(316)  评论(0编辑  收藏  举报