The Dole Queue
Description
The Dole Queue
The Dole Queue |
In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).
Sample input
10 4 3 0 0 0
Sample output
4 8, 9 5, 3 1, 2 6, 10, 7
where represents a space.
#include <iostream>
#include <iomanip>
using namespace std;
int a[1000];
int main()
{int n,l,r,i,j,k;
while(cin>>n,n!=0)
{int N=n;
for(i=0;i<=n+1;i++)
a[i]=0;
cin>>l>>r;
int q=0,p=n+1;
while(N!=0)
{
for(j=1;j<=l;)
{
q++;
if(q==n+1)q=1;
if(a[q]!=1)j++;}
for(k=1;k<=r;)
{ p--;
if(p==0)p=n;
if(a[p]!=1)k++;
}
a[q]=1;
a[p]=1;
if(q!=p){cout<<setw(3) <<q<<setw(3) <<p;N=N-2;}
else if(q==p){cout<<setw(3) <<q;N--;}
if(N!=0)cout<<",";
else cout<<endl;
}
}
return 0;
}
注意输出格式