POJ3624--01背包

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34013   Accepted: 15087

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


基础01背包飘过


源代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<deque>
#include<map>
#include<set>
#include<algorithm>
#include<string>
#include<iomanip>
#include<cstdlib>
#include<cmath>
#include<sstream>
#include<ctime>
using namespace std;

int W[3407];
int D[3407];
int dp[12885];//背包

int main()
{
    int N,M;
    int i,j;
    memset(W,0,sizeof(W));
    memset(D,0,sizeof(D));
    memset(dp,0,sizeof(dp));
    scanf("%d%d",&N,&M);
    for(i = 0; i < N; i++)
    {
        scanf("%d%d",&W[i],&D[i]);
    }
    for(i = 0; i < N; i++)
    {
        for(j = M; j >= W[i]; j--)
        {
            dp[j] = max(dp[j], dp[j - W[i]] + D[i]);
        }
    }
    printf("%d\n",dp[M]);
	return 0;
}


posted @ 2017-11-03 01:43  lemonsbiscuit  阅读(122)  评论(0编辑  收藏  举报